Fix: Add align.h and bug.h to src/common noinst target
[lttng-tools.git] / src / common / Makefile.am
index a8dccc617e0d3dfca1fda305f5671e885e10ec13..61dc3af7c1d7a827d737975d2cd76837391d0a3e 100644 (file)
@@ -7,15 +7,17 @@ AM_CFLAGS = -fno-strict-aliasing
 
 noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
                                 uri.h utils.h lttng-kernel-old.h \
-                                consumer-metadata-cache.h consumer-timer.h
+                                consumer-metadata-cache.h consumer-timer.h \
+                                consumer-testpoint.h align.h bug.h
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
 
 libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        common.h futex.c futex.h uri.c uri.h defaults.c \
-                       pipe.c pipe.h readwrite.c readwrite.h
-libcommon_la_LIBADD = -luuid
+                       pipe.c pipe.h readwrite.c readwrite.h \
+                       daemonize.c daemonize.h
+libcommon_la_LIBADD = -luuid -lrt
 
 # Consumer library
 noinst_LTLIBRARIES += libconsumer.la
This page took 0.023817 seconds and 4 git commands to generate.