Fix: force _lttng python binding to be linked with g++
[lttng-tools.git] / extras / bindings / swig / python / Makefile.am
index 8eea69f32ea637021e0d42f01a12af821dd20aee..d9cdd680d52756541314116896996ee02a5c500f 100644 (file)
@@ -7,10 +7,18 @@ lttng.i: lttng.i.in
 # `swig_this` shadows a global of the same name.  Later versions (like 4.0.1)
 # have renamed this global to `Swig_This_global`.
 #
-# Disable -Wshadow for that file.
-AM_CFLAGS += -Wno-shadow
-
-AM_CFLAGS += -Wno-missing-field-initializers
+# Disable some warning flags for that file.
+AM_CFLAGS += \
+       -Wno-cast-function-type \
+       -Wno-missing-field-initializers \
+       -Wno-null-dereference \
+       -Wno-redundant-decls \
+       -Wno-shadow \
+       -Wno-unused-parameter
+
+# Swig regularily changes and generates code that results warnings which break
+# Werror builds. Disable that option for this sub-project.
+AM_CFLAGS += -Wno-error
 
 AM_CPPFLAGS += $(PYTHON_INCLUDE)
 
@@ -26,6 +34,11 @@ _lttng_la_LIBADD =   $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la               \
                        $(top_builddir)/src/common/libsessiond-comm.la          \
                        $(top_builddir)/src/common/libcommon-gpl.la
 
+# Use this fake source file to force the link mode of the library
+# from gcc to g++. The library contains only C code, but depends on
+# libstdc++.
+nodist_EXTRA__lttng_la_SOURCES = dummy.cpp
+
 lttng_wrap.c: lttng.i
        $(SWIG) -python -I. -I$(top_srcdir)/src/common/sessiond-comm lttng.i
 
This page took 0.023567 seconds and 4 git commands to generate.