update version
[ltt-control.git] / ltt-control / configure.in
index b9b8c831ebb5568cdb184941a6e57a2f131a88ee..cff47676c381e2e02feb7a34c2a3beb4c1162bb4 100644 (file)
 AC_PREREQ(2.57)
 AC_INIT(FULL-PACKAGE-NAME, VERSION, BUG-REPORT-ADDRESS)
 #AC_WITH_LTDL  # not needed ?
-AM_INIT_AUTOMAKE(LinuxTraceToolkitViewer,0.8.31-11032006)
+AM_INIT_AUTOMAKE(ltt-control,0.50-17072008)
 AM_CONFIG_HEADER(config.h)
 AM_PROG_LIBTOOL
 
-AM_PATH_GLIB_2_0(2.4.0, ,AC_MSG_ERROR([glib is required in order to compile LinuxTraceToolkit - download it from ftp://ftp.gtk.org/pub/gtk]) , gmodule)
-
-AM_PATH_GTK_2_0(2.4.0, ,AC_MSG_ERROR([gtk is required in order to compile GUI - download it from ftp://ftp.gtk.org/pub/gtk]) , gmodule)
-
 AC_PATH_PROGS(BASH, bash)
 
 AC_SYS_LARGEFILE
@@ -38,10 +34,6 @@ AC_SYS_LARGEFILE
 # Checks for programs.
 AC_PROG_CC
 
-# Checks for libraries.
-AC_CHECK_LIB([popt], [poptGetNextOpt], POPT_LIBS="-lpopt",AC_MSG_ERROR([libpopt is required in order to compile LinuxTraceToolkit])  )
-#AC_CHECK_LIB([m], [round], M_LIBS="-lm",AC_MSG_ERROR([Mathematical libraries are missing.])  )
-
 AC_CHECK_LIB([util], [forkpty], UTIL_LIBS="-lutil", AC_MSG_ERROR([libutil is
 required in order to compile LinuxTraceToolkit]))
 
@@ -58,8 +50,6 @@ AC_PROG_CC
 AM_PROG_CC_STDC
 AC_HEADER_STDC
 
-pkg_modules="gtk+-2.0 >= 2.0.0"
-PKG_CHECK_MODULES(PACKAGE, [$pkg_modules])
 PACKAGE_CFLAGS="-Wall -Wformat"
 AC_SUBST(PACKAGE_CFLAGS)
 AC_SUBST(PACKAGE_LIBS)
@@ -80,65 +70,21 @@ AC_CHECK_FUNCS([select])
 
 #CPPFLAGS="$CPPFLAGS -I"
 
-AM_CONDITIONAL(LTTVSTATIC, test "$enable_lttvstatic" = yes)
-lttvlibdir="${libdir}/lttv"
-lttvplugindir="${lttvlibdir}/plugins"
-#lttlibdir="${libdir}/ltt"
-top_lttvdir="\$(top_srcdir)/lttv"
-top_lttvwindowdir="\$(top_srcdir)/lttv/modules/gui/lttvwindow"
-
-DEFAULT_INCLUDES="-I\$(top_srcdir) -I\$(top_lttvdir) -I\$(top_lttvwindowdir)"
+DEFAULT_INCLUDES="-I\$(top_srcdir) -I\$(top_builddir)"
 
 #CPPFLAGS="${GLIB_CFLAGS}"
 #AC_SUBST(CPPFLAGS)
 
-lttincludedir="${includedir}/ltt"
-lttvincludedir="${includedir}/lttv"
-lttvwindowincludedir="${includedir}/lttvwindow"
 lttctlincludedir="${includedir}/liblttctl"
 
-AC_SUBST(POPT_LIBS)
+AC_SUBST(lttctlincludedir)
 AC_SUBST(UTIL_LIBS)
 AC_SUBST(THREAD_LIBS)
-AC_SUBST(lttvlibdir)
-AC_SUBST(lttvplugindir)
-#AC_SUBST(lttlibdir)
-AC_SUBST(top_lttvdir)
-AC_SUBST(top_lttvwindowdir)
 AC_SUBST(DEFAULT_INCLUDES)
-AC_SUBST(lttincludedir)
-AC_SUBST(lttvincludedir)
-AC_SUBST(lttvwindowincludedir)
-AC_SUBST(lttctlincludedir)
 
 AC_CONFIG_FILES([Makefile
      liblttctl/Makefile
      lttctl/Makefile
-                lttv/Makefile
-                lttv/lttv/Makefile
-                lttv/modules/Makefile
-                lttv/modules/text/Makefile
-                lttv/modules/gui/Makefile
-                lttv/modules/gui/lttvwindow/Makefile
-                lttv/modules/gui/interrupts/Makefile
-                lttv/modules/gui/diskperformance/Makefile
-                lttv/modules/gui/lttvwindow/lttvwindow/Makefile
-                lttv/modules/gui/lttvwindow/pixmaps/Makefile
-                lttv/modules/gui/controlflow/Makefile
-                lttv/modules/gui/detailedevents/Makefile
-                lttv/modules/gui/statistics/Makefile
-     lttv/modules/gui/filter/Makefile
-     lttv/modules/gui/tracecontrol/Makefile
-                lttd/Makefile
-                ltt/Makefile
-     doc/Makefile
-     doc/developer/Makefile
-     doc/developer/developer_guide/Makefile
-     doc/developer/developer_guide/docbook/Makefile
-     doc/developer/developer_guide/html/Makefile
-     doc/user/Makefile
-     doc/user/user_guide/Makefile
-     doc/user/user_guide/docbook/Makefile
-     doc/user/user_guide/html/Makefile
-     facilities/Makefile])
+     lttd/Makefile
+     specs/Makefile])
 AC_OUTPUT
This page took 0.023099 seconds and 4 git commands to generate.